Some Games Are Currently Unavailable

Incident Report for Sz Games Status

Investigating

We are currently investigating this issue.
Posted Sep 23, 2024 - 05:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 22, 2024 - 00:19 UTC

Investigating

Games Affected:

Run 3

Cat Ninja

Super Mario 64

Smash Karts

Dudgeon Warrior

Tetris

Slide In The Woods


-------------------

We Are Currently Working On a Fix For These Games
Posted Sep 21, 2024 - 19:09 UTC
This incident affects: Games.