Main Link Is Down
Incident Report for Sz Games Status
Resolved
The Site Is Back Up!
Posted Nov 14, 2024 - 01:23 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2024 - 21:02 UTC
Investigating
The Main Link is currently Down please check out discord for updates

https://discord.gg/XaEPUtUZ7G
Posted Nov 08, 2024 - 21:02 UTC
This incident affected: Games, CDN, and Main Page.